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I. Changes and Enhancements Made in SEE Electrical 
Expert V4R3 Service Pack 3 (4.83/A) Compared to V4R3 
Service Pack 2 (4.82/D) 

 

I.A. New Features and Enhancements 
 

Project 

 
▪ Possible to extract via API all XML files corresponding to the equipment codes stored in 

the project. 
 
 

Schematic, Layout, Synoptic and Harness Editors 

 
▪ The option "Translatable" was added: 

 In the particular dialogues for changing the properties of texts and/or attributes; 

 In the dialogue for changing symbol's attributes, which contains all attributes of the 
respective symbol.  

▪ Import DXF/DWG method: in all available tables, the allowed maximum number of lines 
(for listing various entities) is increased. 

 
 

Electric Data Explorer 

 
▪ In the Cables tab, possible to sort the cables by Label. 

 
 

Symbol Editor 

 
▪ Improvements concerning the "DXF/DWG Block Name" attribute: 

 Possible to enter several values, separated by comma; 

 Possible to use the character "*" at the beginning or/and at the end of a Block 
Name, in order to indicate that all digits are accepted (respectively, at the 
beginning or/and at the end of the entered name). 

 
 

3D Panel 

 
▪ When Equipment from a different location is imported in a given 3D Panel location, this 

Equipment automatically obtains the location of the 3D Panel (in which imported). 
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SEE Automatic Diagram Generation 

▪ The SEE Excel Sheet Generator tool has become a SEE Electrical Expert Plugin. 
▪ The structure of the tool has been modified, in order that it is able to manage accentuation 

or specific characters like the Chinese ones. 
 
 

PLC I/O Manager 

▪ Possible to import an Access file (file of MDB type) that contains a configuration in "IGE" 
format. 

▪ A new dialogue, displayed during importation of PLC configurations that already exist, 
allows adding the imported configuration to the respective existing one, replace one of the 
PLC stations or replace all of them. 

▪ Contextual menu simplification: all pop-up menus that contained only one 
command/option to choose have been moved to the upper level. 

▪ The PLC Plugin, which allows manual channel insertion, updated so that the new 
configuration file: APIGENERATION.XML can be read (in previous versions the file used 
was GENFOL.MDB) 

 
 
 

I.B. Fixed Issues 
 
 
3D Panel 

BM605215 While working with a 3D project, the Save button does not work.  

 
 
Blocks 

BM23651 The Refresh command does not work. 

 
 
Cables 

BM20926 Impossible to add an attribute on a cable inserted in a graphical 
location. 

BM23748 In the dialogue called via the command Insert > Define Connection 
Cabling – Options button, impossible to disable the "Insert wire 
symbols…" option. 

BM1401619 At the insertion of a second cable, the equipment code assigned to the 
previous one is not taken into account. 

 
Connectors 

BM23637 Crash when opening the CAD Properties window from a connector's 
pin. 

BM23671 Harness related information not displayed for equipment codes of pins 
(in generated equipment lists). 

BM605226 Impossible to insert shielded pins when all pins are used. 
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Copy/Paste 

BM23561 When pasting a Backshell pin in the same connector, the pasted pin 
takes a new connector tag 

BM605288 
Display of the GUID instead of the Tag after pasting an End Cap 
symbol 

 
 
Documentation 

BM23784 Modification in the synoptic sheet help. 

 
 
Electric Data Explorer (EDE) 

BM605277 
In the Sheets tab, the Show information column command does not 
display any information - the Informations column is always empty.  

 
 
Environment Manager 

BM23818 
When comparing the active and the project Environments, the Title 
Blocks, Parameter Sheets and Slf files appear in the created differential 
environment even if they are identical in both compared environments. 

 
 
DWG/DXF 

BM23572 DWG lines are imported as Drawings instead of being imported as 
Connections. 

 
 
Harness Editor 

BM605230 Impossible to match a symbol with "Harness" function / "Harness 
GroundBlock" behaviour, from a Harness diagram, with a symbol 
having "Terminal Strip & Connector" function / "Connector Ground" 
behaviour (Schematic Diagram). 

BM1301001 Lost the cables tags in the table when updating the WD attributes. 

 
 
List Reports 

BM1301031 
The special character: "&" is replaced by "&amp;" if this one is 
contained in a "Catalog" attribute. 

 
 
Messages 

BM23716 Wrong message displayed when inserting (drawing) a curve without 
angle. 

BM23735 In the French version, incorrect translation in the repository dialogue. 

BM1301013 In the settings dialogue, change "Edición" by "Editores" (Spanish 
version). 
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BM1700122 Wrongly translated text in dialogues. 

BM1700125 Incorrect translation for the Chinese version. 

 
 
Other 

BM23455 Add or Modify field into multiple classes command in the Equipment 
Catalogue (Tools menu): Lost the field name if you select the function 
before entering the name (when adding a new field). 

 
 
PLC I/O Manager 

BM605272 After a project conversion from version V4R2, channels have a wrong 
position. 

 
 

Schematic Editor 

BM605245 Impossible to move the entire schematic diagram in a wire project.  

 
 

Sheets Explorer 

BM23420 Impossible to create a location on a new group. 

BM605247 An error message displayed when executing drag & drop of a sheet 
from a group to another one. 

BM1602484 Crash when executing a right-click on the groups. 

 
 
Signals 

BM22989 Wrong starting number when numbering by symbol. 

 
 
Symbols 

BM1301018 When inserting a symbol via equipment selection, no equipment code is 
displayed (in the equipment selection dialogue). 

 
 
Title Block 

BM23284 Incorrect Metacommand attributes list. 

 
 
Translation 

BM23743 The "Word-to-Word Translation" option does not work correctly 
(Translation Settings window). 

BM23754 Some sentences are not translated if the "Word-to-Word Translation" 
option is selected. 

BM23756 Filter on the words with numbers does not work correctly. 

BM23771 The not translatable characters are duplicated after the translation. 
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I.C. Known Issues and Workarounds 
 
 

Issues to be fixed in V4R3 Service Pack 4 (4.84/A) 

 
3D Panel 

BM605214 After creating a 3D project and deleting it, the Load From Location 
command does not work properly (in a newly created project). 

BM605216 The drilling defined via the command Print > Define Print Views is not 
displayed correctly. 

 
 
Copy/Paste 

BM1401585 When pasting multiple copied terminals several times, the order number 
(of some of them) is incorrect. 

 
 
DWG/DXF 

BM23415 Impossible to use the $TAG attribute in the Symbols tab of the Import 
DXF/DWG method. 

 
 
Environment Method 

BM1700113 Symbol Tagging method: In the Numbering tab, impossible to reset 
by group name the order number of the symbol tag. 

 
 
OLE Object 

BM1401579 OLE Object insertion does not work for Windows 10 version 1703 

 
 

Schematic Editor 

BM1401573 Navigation: Hyperlinks are not displayed in the Cable CAD Properties 
dialogue  

 
 
Translation 

BM23443 Necessary to have the position settings available in the Translation 
dialogue (called from the Process menu), in order to set different 
positions for the translated text, in the different languages, without 
opening the method. 
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I.D. Limitations and Restrictions 
 
 

I.D.1. SEE Electrical Expert 
 
 SEE Electrical Expert cannot be run under Windows XP. 

 
 SEE Electrical Expert V4R3 needs a Flex LM version that is equal or upper to 11.14.02 to use 

this type of protection. The "Visual C++ Redistribute for Visual Studio 2015" component has 
to be installed on the server where Flex LM is installed. Normally, this component is 
automatically installed with the Windows Update. 

 
 Project maximal size is 1.8 GB. 

 
 The multi-language features of a project are protected by the "Translation" license.  

Editing texts or attributes is possible to be carried out in all project languages only provided you 
have the "Translation" module included in your license. 
If you do not have the "Translation" module, you are allowed to consult the project in each project 
language but modifications can only be made in the "main" language. 

 
 The migration process does not recreate the hyperlinks in projects created with V4R1 or 

previous versions of SEE Electrical Expert. To have the hyperlinks available on migrated 
projects, you have to rebuild the cross references and then generate the part lists and table of 
contents again. 

 
 PDF Export: To activate the hyperlinks in Adobe Acrobat Pro, click Edit > Preferences…, 

select the Documents category in the left pane of the displayed Preferences window  and then 
choose "Never" from the drop-down list available for the "View documents in PDF/A mode" 
setting. 

 
 SEE Workspace (SWS files generated through Options/Customize - Export button) that were 

saved with versions lower or equal to V4R1 are not supported by V4R3. 
 
 SEE Equipment Database supports MS SQL Server 2008, 2012 and 2014 ("Part List 

Manager" license is required). 
 
 Versions greater or equal to V4 do no longer support MS SQL or Oracle database for the 

parts list processes. 
 
 If you are using Local Server Borrowing (LSB) or Internet License Server (ILS) Protection, it is 

impossible to change the software language after the installation. 
 
 In the Equipment Catalogue, the "Date of update" field is automatically updated at execution of 

the relevant functionalities that allow/initiate creation, importation and modification of Equipment 
Codes 

However, there are particular cases when the field is not updated – these are: 

 Modification of Equipment Codes directly in the Access base. 

 Download of Equipment Codes from CSV and XML files. 
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 Download of Equipment Codes having ASCII Formatted format, dBase format and 
Class format. 

 Modification of a field value via the command Edit > Change field value…. 

 Modification of a field via the command Tools > Add or Modify field into 
multiple classes. 

 
 PLC I/O Manager: 

 With Block Generation option activated (in the Options menu), it is impossible 
to export interfaces in the generated PLC sheets (this process is only possible 
when the Slf Generation option is activated). 

 Impossible to import configurations with formats: 
▪ FNE, EDI LOG and TXT. 
▪ ACCESS with a structure different from IGE format. 

 Impossible to export a configuration. 

 In a configuration, it is impossible to define several blocks of intermediary cards. 
 
 The Block Variables Editor does not retrieve attributes from Blocks and Standard Diagrams 

created in Layout sheets. 
It retrieves only symbols' Location and Function from Blocks and Standard Diagrams created in 
Synoptic sheets. 

 
 
 

I.D.2. SEE Electrical 3D Panel 
 
 SEE Electrical 3D Panel has its own installer and is not installed with SEE Electrical Expert.  

 
 
 

I.D.3. SEE Automatic Diagram Generation Module 
 
 The SEE Automatic Diagram Generation module has its own installer and is not installed with 

SEE Electrical Expert. 
 This module is protected by a license. 
 The SEE Automatic Diagram Generation module needs MS Excel and is compatible with the 

32 and 64 bits versions of MS Excel 2010, 2013 and 2016. 
 It is not possible to add variables for layout or harness blocks in the Block Param Editor. 

 
 
 

I.D.4. Concurrent Engineering Module (Multi-User Mode) 
 
 The Concurrent Engineering module (Multi-User mode) works with MS SQL Server 2012 

and 2014 database to store project data. 
 The Concurrent Engineering module needs SEE Access Control. 
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 In Multi-User mode (Concurrent Engineering module), the option "Automatically save project 

content when closing project" (in the Settings window of SEE Electrical Expert) does not 
work when not enabled. 

 
 
 

I.D.5. Open Data Module 
 
 The Open Data module needs MS Excel and is compatible only with the 32-bits version. 

 
 
 

I.D.6. End Fitting Module 
 
 To migrate the data stored in cable attributes (until V4R1) to the new V4R3 extremity attributes, 

the "End Fitting migration to V4R3 (4.80)" plugin must be installed and activated. 
 
 
 

I.D.7. 3D Panel For SolidWorks Module 
 
 The "old" 3D Panel for SolidWorks module is no longer supported by SEE Electrical Expert 

versions that are greater or equal to V4R3. 
 A 3D panel layout created with this module (before V4R3) cannot be migrated to the new 3D 

Panel module. 
 
 
 

I.D.8. Macro 
 
 To execute a macro on SEE Electrical Expert versions greater or equal to V4R3, you need to 

have a VBA version 7.1 32 bit (not 64 bit) installed.  
 
 
 

I.D.9. SmarTeam Integration Module 
 
 The SmarTeam Integration module of SEE Electrical Expert V4, V4R1, V4R2, and V4R3 

supports the SmarTeam releases V5R19 to V5R27. 
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I.E. Compatibility with Other IGE+XAO Products 
 

I.E.1. SEE Project Manager 
 
SEE Electrical Expert V4R3 Service Pack 3 (4.83/A) is compatible with SEE Project Manager V8R2 
SP 7 - Patch K or L, and V8R3 Patch C. 
 
 
 

I.E.2. SEE Access Control 
 
SEE Electrical Expert V4R3 Service Pack 3 (4.83/A) supports only the version 4.50/E of SEE Access 
Control. 
Customers using older SEE User Access versions have to migrate their databases via the SEE 
Access Control Admin Tool. 
 
 
 

I.E.3. SEE Automatic Diagram Generation 
 
SEE Electrical Expert V4R3 Service Pack 3 (4.83/A) supports the version V4.80/A of SEE Automatic 
Diagram Generation. 
 
 
 

I.E.4. SEE Electrical 3D Panel 
 
SEE Electrical Expert V4R3 Service Pack 3 (4.83/A) supports V1R4 Service Pack 1 of SEE 
Electrical 3D Panel. 
 
 
 

I.E.5. SEE Electrical Jigboard 
 
SEE Electrical Expert V4R3 Service Pack 3 (4.83/A) supports the version V4R7 of SEE Electrical 
Jigboard.  
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I.F. System Requirements 
 

I.F.1. Advisable System Configuration 
 

For Mono-User Mode: 

▪ Microsoft Windows 7 Home Premium, Professional, Ultimate, Enterprise  
▪ 64 bits Operating System to be installed on a 64 bits computer 
▪ Processor: i3 class, 2 GHz. 
▪ RAM: 4 GB. 
▪ 500 MB of free disk space required for the installation. 
▪ In order to optimize the SEE Electrical Expert performance on your computer, it is 

recommended that you use an SSD hard drive 
▪ Graphic Card: 1280 x 1024. 

 
 

For Multi-User Mode (Concurrent Engineering): 

The requirements are different for the Server and for the Client. 
 
For the Server: 
▪ Microsoft Windows Server 2008 R2 64 bits or newer. 
▪ Microsoft SQL Server 2008 R2 (PROFESSIONAL version strongly 

recommended; EXPRESS EDITION version possible to be used with limitations). 
▪ Processor: i7 class, 3 GHz. 
▪ RAM: 12 GB (+ 1 GB by client). 
▪ 200 GB of free disk space required for the installation. 
▪ LAN (Network Card): 1 GB. 
 
For the Client: 
▪ Microsoft Windows 7 (64 bits). 
▪ Processor: i3 class, 2 GHz. 
▪ RAM: 4 GB. 
▪ 500 MB of free disk space required for the installation. 
▪ In order to optimize the SEE Electrical Expert performance on your computer, it is 

recommended that you use an SSD hard drive 
▪ Network Card: 1 GB. 
▪ Graphic Card: 1280 x 1024. 
 
 

For using the 3D Panel: 

▪ Microsoft Windows 7 Home Premium, Professional, Ultimate, Enterprise. 
▪ Processor: i5 class, 2 GHz. 
▪ RAM: 4 GB. 
▪ 1 GB of free disk space required for the installation with the 3D Parts library 

provided by default. 
▪ Graphic Card: full support of OpenGl required, as well as 1 GB of dedicated 

memory. 
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I.F.2. Windows Compatibility 
 
 
SEE Electrical Expert V4R3 supports: 
 Microsoft Windows 10 Pro (32 and 64 bits), as well as Microsoft Windows 10 Enterprise (32 

and 64 bits). 
 Microsoft Windows 8 and Microsoft Windows 8.1 (except for the RT version for mobile 

devices). 
 Microsoft Windows 7. 
 

Microsoft Windows XP is not supported by SEE Electrical Expert V4R3. 
 
 
 

I.F.3. Virtual Solutions Compatibility 
 
 
SEE Project Manager and SEE Electrical Expert are compatible with the Microsoft App-V and 
VMWare virtual solutions. 
 

Microsoft App-V or VMWare 

 
No compatibility issues reported for these two virtual solutions. 


