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I. Changes and Enhancements Made in SEE Electrical 
Expert V4R3 Service Pack 7 - 4.87/A Compared to V4R3 
Service Pack 6 - 4.86/C 

 

I.A. New Features and Enhancements 
 

3D Panel 

▪ External tagging kept after loading more than once a wire created in SEE Electrical 
Expert. 

 

 

3D View Insertion 

▪ Possible to insert a very big 3D Print view in the schematic sheet (via the command 
Insert > Insert 3d View) – a setting added in the registry allows cancelling the size 
limitations for the inserted vector images. 

 

 

Copy/Paste 

▪ At the execution of Paste special, the existing locations and functions are sorted 
alphanumerically in the corresponding tabs of the Copying Parameters dialogue. 

▪ Paste special improved so that the symbols belonging to a family not existing in the 
environment are also copied/pasted. 

 

 

Connective Equipment Insertion 

▪ Improved the process Automatic insertion of Harness Connective Equipment. 
When launched on a cable connected to only two pieces of Harness Connective Equipment, 
these ones are positioned opposite to each other by the insertion process.  

 

 

Data Extraction by Location 

▪ A new dialogue added to allow selection of the Locations from which to extract the data. 
 

 

E-Catalogue 

▪ Enhanced the display of the grid listing the available PNs (possible to be chosen) in the 
Equipment selection dialogue. 
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Environment 

▪ Possible to assign a particular standard (IEC, IEEE, CEI-IEC, etc.) to an environment. 
 

 

JSON Sheet Generation 

▪ Enhancement in the process so that sheets are generated in the order they are displayed 
in the Sheet Explorer. 

 

 

Plugins 

▪ Reorganized the Final folder structure for the Open Data plugin. 
 

 

Protection 

▪ License not checked when the "Next" tagging mode is applied for cables. 
 

 

SEE Automatic Diagram Generation 

▪ Added an option that enables choosing whether to keep the symbols definitions or update 
them according to the respective project symbols 

 

 

Symbol Export 

▪ Improved the symbol exportation to Jigboard format to retrieve the line style and colour, 
with possibility for modifying the line style. 

 

 

API 

▪ For the insertion of a Block containing a symbol definition different from that in the 
environment, added the possibility for choosing between the original symbol definition and 
the environment symbol definition. 

▪ Created new API methods – for retrieving elements (Symbols, Connectors, Cables, 
Terminal Strips) by tag. 

 

 

XML 

▪ Modified the PassThrough and EndFitting management  
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I.B. Fixed Issues 
 

Blocks 

Ticket ID: 7594 After inserting a block, some pins are missing. 

 

 

Configurator 

Ticket ID: 5762 Impossible to find the environment path. 

 

 

Copy/Paste 

Ticket ID: 7417 
If symbols do not exist in the environment, these ones are not "copied" 
with a Paste special. 

Ticket ID: 7483 After Paste special, the locations are not sorted. 

 

 

Ergonomy 

Ticket ID: 8127 Bad default size of the Attribute window in the French version. 

 

 

Installation 

Ticket ID: 8026 Incorrect name and description of the new block OPR plugin. 

 

 

Options & Variants 

Ticket ID: 7954 
Lost sheet validity after copying/pasting a text/symbol/drawing from a 
sheet into another one. 

 

 

Other 

Ticket ID: 6240 
ADG: When inserting several times the same block, the symbols and/or 
connections are not tagged. 

Ticket ID: 6516 Impossible to insert a very big 3D Print view. 

Ticket ID: 7748 Performance: Terminal strip sheets generation regression. 

Ticket ID: 7824 Performance: slowdown when working with this environment. 
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PLC I/O Manager 

Ticket ID: 6496 
PLC module does not work when a network access path is specified as 
the environment root directory. 

Ticket ID: 7685 
In the generated sheets, the last term used in the mnemonic is 
repeated. 

 

 

Plugins 

Ticket ID: 8843 
See PDM Connect: When closing the project without saving it, the 
generated XML files are wrong. 

 

 

Printing 

Ticket ID: 7965 
Texts contained in object groups are not generated in the CGM/SVG 
files 

 

 

Signals 

Ticket ID: 6217 Lost the signal labels positions when removing signal numbers. 

 

 

Symbols 

Ticket ID: 7394 
After changing the English description of symbol family, the Polish 
description is displayed. 

 

 

Translation 

Ticket ID: 7655 The non-translatable text disappears after the translation. 

Ticket ID: 8159 
Some sentences are not translated if the "Word-to-word Translation" 
option is enabled. 

 

 

Terminals 

Ticket ID: 7717 
The "Authorize generation of several terminal strips per sheet" 
option does not work. 

Ticket ID: 8753 Crash when generating all terminals strips. 
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I.C. Known Issues and Workarounds 
 

Issues to be fixed in V4R3 Service Pack 7 (4.87/B) 

 

2D Panel 

Ticket ID: 7924 
When pasting the equipment code of a rail to another one, its 
dimensions are not updated. 

 

 

3D Panel 

Ticket ID: 581 In Net Mode, the length of the wires is not retrieved in SEE XP. 

 

 

Blocks 

Ticket ID: 9050 Signal Number lost after block insertion. 

 

 

Cables 

Ticket ID: 4400 Cannot update the names of the strands of inserted cables. 

Ticket ID: 5323 Cannot have an "empty" value in the Gauge field. 

Ticket ID: 6444 
The process (of tagging) does not take into account the inverted 
locations. 

 

 

Copy/Paste 

Ticket ID: 7383 Incorrect cable location (From/To) after using Paste special. 

 

 

Connectors 

Ticket ID: 5705 Lost equipment code in pin's CAD attributes. 

 

 

DXF/DWG 

Ticket ID: 8246 
The blocks are imported on the creation layer, and not on the insertion 
layer. 

Ticket ID: 8399 Shift of the cross referencing after a DWG exportation. 
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Label Export 

Ticket ID: 7890 Incorrect terminal labels exported with Wago. 

Ticket ID: 8541 The calculated number of labels is incorrect. 

Ticket ID: 8703 Incorrect label number for wires. 

Ticket ID: 9051 
Some cable wires are extracted in wire file (when only connections are 
selected) 

 

 

Options & Variants 

Ticket ID: 8848 Crash when saving a project with a validity. 

 

 

Other 

Ticket ID: 6454 The filter on the manufacturer takes 27s to be displayed. 

Ticket ID: 6457 
PN Choice: Fit the height of the frame containing the grid to the height 
of the integrated SEE Database Browser. 

 

 

Project 

Ticket ID: 8228 
Do not save in the project the equipment catalogue images assigned to 
symbols. 

 

 

Protection 

Ticket ID: 7636 
In a customer project, impossible to insert a cable if Labeling is not 
programmed. 

Ticket ID: 7642 Error message about the bundle when launching the software. 

Ticket ID: 7783 
With a LLS, the license borrowed for 90 days is blocked after about 11 
days. 

Ticket ID: 7849 
Launching SEE Electrical Expert V4R3 causes spontaneous 
reprogramming of the NetHASP protection key. 

 

 

Report Lists 

Ticket ID: 8770 Incorrect table of contents if the group level is equal to 9. 
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Ticket ID: 8830 Cannot generate the part list. 

Ticket ID: 8984 
At symbol list extraction/generation, the location is not extracted for 
some black boxes. 

 

 

Sheets 

Ticket ID: 7596 Impossible to rename a group after inserting a block in a new sheet. 

 

 

Symbols 

Ticket ID: 7809 
Cannot validate again an equipment code on a symbol if the Minimum 
input voltage or Maximum input voltage field is empty. 

Ticket ID: 8553 
In the contextual menu on a cable symbol, the Layout Sheet sub-
command (of the Go to contextual command) is displayed twice. 

Ticket ID: 8780 Impossible to select a Part Number with voltage for a connection. 

Ticket ID: 8953 
For the black boxes, the values of Connection point User attributes are 
not saved. 

 

 

Terminals 

Ticket ID: 6677 Syntax error in the terminal strip settings. 

Ticket ID: 8165 
Incorrect numbering on a multi-level terminal when using several types 
of terminals. 

 

 

Xelec Convertor 

Ticket ID: 5907 Problem with redirections in environments. 

Ticket ID: 8863 Missing texts in dialogues. 

 

 

 

I.D. Limitations and Restrictions 
 

I.D.1. SEE Electrical Expert 
 

 SEE Electrical Expert cannot be run under Windows XP. 
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 SEE Electrical Expert V4R3 needs a Flex LM version that is equal or upper to 11.14.02 to use 
this type of protection. The "Visual C++ Redistribute for Visual Studio 2015" component has 
to be installed on the server where Flex LM is installed. Normally, this component is 
automatically installed with the Windows Update. 

 

 Project maximal size is 1.8 GB. 
 

 The multi-language features of a project are protected by the "Translation" license.  
Editing texts or attributes is possible to be carried out in all project languages only provided you 
have the "Translation" module included in your license. 
If you do not have the "Translation" module, you are allowed to consult the project in each project 
language but modifications can only be made in the "main" language. 

 

 The migration process does not recreate the hyperlinks in projects created with V4R1 or 
previous versions of SEE Electrical Expert. To have the hyperlinks available on migrated 
projects, you have to rebuild the cross references and then generate the part lists and table of 
contents again. 

 

 PDF Export: To activate the hyperlinks in Adobe Acrobat Pro, click Edit > Preferences…, 
select the Documents category in the left pane of the displayed Preferences window  and then 
choose "Never" from the drop-down list available for the "View documents in PDF/A mode" 
setting. 

 

 SEE Workspace (SWS files generated through Options/Customize - Export button) saved 
with versions lower or equal to V4R2 not supported by V4R3. 

 

 SEE Equipment Database supports MS SQL Server 2008, 2012 and 2014 ("Part List 
Manager" license is required). 

 

 Versions greater or equal to V4 do no longer support MS SQL or Oracle database for the parts 
list processes. 

 

 If you are using Local Server Borrowing (LSB) or Internet License Server (ILS) Protection, it is 
impossible to change the software language after the installation. 

 

 Equipment Catalogue: the "Date of update" field is automatically updated at execution of the 
relevant functionalities that allow/initiate creation, importation and modification of Equipment 
Codes 

However, there are particular cases when the field is not updated – these are: 

 Modification of Equipment Codes directly in the Access base. 

 Download of Equipment Codes from CSV and XML files. 

 Download of Equipment Codes having ASCII Formatted format, dBase format and 
Class format. 

 Modification of a field value via the command Edit > Change field value…. 

 Modification of a field via the command Tools > Add or Modify field into 
multiple classes. 
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 PLC I/O Manager: 

 With Block Generation option activated (in the Options menu), it is impossible 
to export interfaces in the generated PLC sheets (this process is only possible 
when the Slf Generation option is activated). 

 Impossible to import configurations with formats: 

▪ FNE, EDI LOG and TXT. 
▪ ACCESS with a structure different from IGE format. 

 Impossible to export a configuration. 

 In a configuration, it is impossible to define several blocks of intermediary cards. 

 

 Environment Manager: The Merge, Compare and Update processes work only between 
environments that have the same structure (i.e. the same Classes and Fields). 

 

 Block Variables Editor:  

 does not retrieve attributes from Blocks and Standard Diagrams created in Layout 
sheets. 

 retrieves only symbols' Location and Function from Blocks and Standard Diagrams 
created in Synoptic sheets. 

 

 

 

I.D.2. SEE Automatic Diagram Generation Module 
 

 The SEE Automatic Diagram Generation module has its own installer - it is not installed with 
SEE Electrical Expert. 

 This module is protected by a license. 
 The SEE Automatic Diagram Generation module needs MS Excel and is compatible with the 

32 and 64 bits versions of MS Excel 2010, 2013 and 2016. 
 It is not possible to add variables for layout or harness blocks in the Block Param Editor. 

 

 

 

I.D.3. Concurrent Engineering Module (Multi-User Mode) 
 

 The Concurrent Engineering module (Multi-User mode) works with MS SQL Server 2012 and 
2014 database to store project data. 

 The Concurrent Engineering module needs SEE Access Control. 
 In Multi-User mode (Concurrent Engineering module), the option "Automatically save project 

content when closing project" (in the Settings window of SEE Electrical Expert) does not 
work when not enabled. 
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I.D.4. Open Data Module 
 

 The Open Data module needs MS Excel and is compatible only with the 32-bits version. 
 

 

 

I.D.5. End Fitting Module 
 

 To migrate the data stored in cable attributes (until V4R1) to the new V4R3 extremity attributes, 
the "End Fitting migration to V4R3 (4.80)" plugin must be installed and activated. 

 

 

 

I.D.6. 3D Panel For SolidWorks Module 
 

 The "old" 3D Panel for SolidWorks module is no longer supported by SEE Electrical Expert 
versions that are greater or equal to V4R3. 

 A 3D panel layout created with this module (before V4R3) cannot be migrated to the new 3D 
Panel module. 

 

 

 

I.D.7. Macro 
 

 To execute a macro on SEE Electrical Expert versions greater or equal to V4R3, you need to 
have a VBA version 7.1 32 bit (not 64 bit) installed.  

 

 

 

I.D.8. SmarTeam Integration Module 
 

 The SmarTeam Integration module of SEE Electrical Expert V4, V4R1, V4R2, and V4R3 
supports the SmarTeam releases V5R19 to V5R27. 
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I.E. Compatibility with Other IGE+XAO Products 
 

I.E.1. SEE Project Manager 
 

SEE Electrical Expert V4R3 Service Pack 7 (4.87/A) is compatible with SEE Project Manager V8R2 
SP7 - Patch K or L, and V8R3 Patch C. 

 

 

 

I.E.2. SEE Access Control 
 

SEE Electrical Expert V4R3 Service Pack 7 (4.87/A) supports only the version 4.50/E of SEE Access 
Control. 

Customers using older SEE User Access versions have to migrate their databases via the SEE 
Access Control Administration Tool. 

 

 

 

I.E.3. SEE Automatic Diagram Generation 
 

SEE Electrical Expert V4R3 Service Pack 7 (4.87/A) supports the version V4.82/A of SEE Automatic 
Diagram Generation. 

 

 

 

I.E.4. SEE Electrical Jigboard 
 

SEE Electrical Expert V4R3 Service Pack 7 (4.87/A) supports the version V4R7 of SEE Electrical 
Jigboard.  
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I.F. System Requirements 
 

I.F.1. Advisable System Configuration 
 

For Mono-User Mode: 

▪ Microsoft Windows 7 Home Premium, Professional, Ultimate, Enterprise  
▪ 64 bits Operating System to be installed on a 64 bits computer 
▪ Processor: i3 class, 2 GHz. 
▪ RAM: 4 GB, but strongly recommended are 8 GB. 
▪ 500 MB of free disk space required for the installation. 
▪ In order to optimize the SEE Electrical Expert performance on your computer, it is 

recommended that you use an SSD hard drive 
▪ Graphic Card: 1280 x 1024. 

 

 

For Multi-User Mode (Concurrent Engineering): 

The requirements are different for the Server and for the Client. 
 
For the Server: 
▪ Microsoft Windows Server 2008 R2 64 bits or newer. 
▪ Microsoft SQL Server 2008 R2 (PROFESSIONAL version strongly 

recommended; EXPRESS EDITION version possible to be used with limitations). 
▪ Processor: i7 class, 3 GHz. 
▪ RAM: 12 GB (+ 1 GB by client). 
▪ 200 GB of free disk space required for the installation. 
▪ LAN (Network Card): 1 GB. 
 
For the Client: 
▪ Microsoft Windows 7 (64 bits). 
▪ Processor: i3 class, 2GHz3 class, 2 GHz. 
▪ RAM: 4 GB. 
▪ 500 MB of free disk space required for the installation. 
▪ In order to optimize the SEE Electrical Expert performance on your computer, it is 

recommended that you use an SSD hard drive 
▪ Network Card: 1 GB. 
▪ Graphic Card: 1280 x 1024. 
 
 

For using SEE Electrical 3D Panel: 

▪ Microsoft Windows 7 Home Premium, Professional, Ultimate, Enterprise. 
▪ Processor: Intel® Core™ i7 >3 GHz or equivalent. 
▪ RAM: 8 GB. 
▪ 1 GB of free disk space required for the installation with the 3D Parts library 

provided by default. 
▪ Graphic Card: NVIDIA GeForce® GTX 4 GB of dedicated memory, or equivalent. 
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I.F.2. Windows Compatibility 
 

SEE Electrical Expert V4R3 supports: 

 Microsoft Windows 10 Pro (32 and 64 bits), as well as Microsoft Windows 10 
Enterprise (32 and 64 bits). 

 Microsoft Windows 8 and Microsoft Windows 8.1 (except for the RT version for 
mobile devices). 

 Microsoft Windows 7. 

 

▪ Microsoft Windows XP is not supported by SEE Electrical Expert V4R3. 

 

 

 

I.F.3. Virtual Solutions Compatibility 
 

SEE Project Manager and SEE Electrical Expert are compatible with the Microsoft App-V and 
VMWare virtual solutions. 

 

Microsoft App-V or VMWare 

 
No compatibility issues reported for these two virtual solutions. 


