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I. New Features 
 

I.A. Creation and Validation of a Work Environment within the 
Environment Explorer 

 
 
The new command: Create a work environment, added in the pop-up menu available on the active 
environment, enables you to create a temporary working environment from the active one.  
 
The environment, created via this command, represents a copy of the active environment, and bears 
the same name with the suffix "_InWork" added.  
The working is indicated by a specific icon in the Environment Explorer, and the following 
contextual menu is available on it: 
 

 
 
 The Activate command makes the environment available to other users 
 When the new command: Validate is executed, the corresponding "original" environment is 

automatically archived and the working environment becomes a new "index" of the archived 
one. 

 
Only the environment creator or a user assigned with relevant rights is allowed to activate the 
working environment or to create new projects using templates from that environment. 
 
 
 

I.B. Innovations in the Environment Manager 
 

I.B.1. New Command to Compare the Active and Project 
Environments 

 
 
The new command Environment > Compare active and project environment, protected by the 
Environment Manager module, allows you to create a new environment resulting from comparing the 
active environment with a temporary one that contains the elements used in the current project. 
 
At the execution of the command, the following automatic processes are consecutively run: 
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 A temporary environment is created from the current project with the same name as the active 
environment, and stored in a temporary folder.  

 Comparison is done between the two environments - the active one is treated as a reference 
(known as "source" so far) and the newly created temporary environment – as a local 
environment (known as "destination environment" so far). 

 A new environment, containing the "differences" detected between the two compared 
environments is generated in the "SEE_Env" folder, and named: "Env_{Project Name}". 

 
A relevant log file is displayed at the end of the entire process. 
 
 
 

I.B.2. New Update Mode to Synchronize Two Environments 
 
 
The new option: "Synchronize", available in the Environment manager settings dialogue, enables 
you to perform bidirectional update between your reference and local environments, as long as they 
are from a V4R3 version of SEE Electrical Expert.  
 

The synchronization process takes into account the relevant elements of the two environments that are 
treated: Symbols, Illustrations, Translation terms, Parameter Sheets, Sheet Generator, Blocks, 
Templates, Title Blocks and Equipment Catalogue of MDB format (SQL format to be managed in SEE 
Electrical Expert V5).  

 
When the "Synchronize" option is activated, a "Priority" environment must be specified in order to 
set the start of the process - this can be either the "Reference" or the "Local" environment:  
 

 
 
The "Priority" is to indicate that the synchronization is to start by adding the "new" elements existing 
in the specified "priority" environment to the secondary one and full update is to be done from the 
priority environment to the other environment. After that, relevant update is to be done from the 
secondary environment to the priority one. 
 
 At the first synchronization treatment, launched on a given environment, the update is 

performed according the rules applied when the "New and modified" option is activated, by 
considering the specified priority. During the process, a relevant "Synchronization.xml" file is 
created in:  

"…\IGE+XAO\SEE Electrical Expert V4R3\4.8\SEE_Env\<ENVIRONMENT_NAME>\Other".  
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 At the next synchronizations performed for that environment, the XML file is initialized with the 
date of the last executed synchronization.  

For each next synchronization, the process compares the stored synchronization date with the 
last modification date of each element of the treated environment components. 
 
The synchronization runs through the following consecutive stages: 

 
▪ Comparing the dates of the last modification for the elements from the priority 

environment with the last synchronization date recorded in the "Synchronization.xml" file. 

 When the modification date of an element – e.g. symbol from the priority 
environment is later than the last synchronization date, this symbol replaces the 
corresponding one in the other environment.  

In case a corresponding symbol does not exist, the symbol from the priority 
environment is automatically created in the other one. 

 When the date of a symbol modification in the priority environment precedes the 
synchronization date, no change is done on the corresponding symbol in the other 
environment. 

When a corresponding symbol is missing in the other environment, it is considered 
deleted.  

 
▪ Comparing the last modification dates of the elements in the other environment with the 

last synchronization date. 

 When the modification date of a symbol from the other environment is later than 
the last synchronization date, this symbol replaces the corresponding one in the 
priority environment. 

In case a corresponding symbol does not exist, the symbol is kept in the other 
environment but is not created in the priority one. 

 When a symbol's modification date in the other environment is earlier than the 
synchronization date, no change is done. 

 
When the entire synchronization process is over, a detailed log file is generated. 

 
Important! The synchronized update can be launched only on environments with the same structure 
- therefore it is only possible for two environments created for the V4R3 version of SEE Electrical 
Expert. 
 
 
 

I.B.3. New Setting for Automatic Update  
 
 
A new setting, available in the Environment manager settings dialogue, allows you to enable the 
automatic update of the local environment when the software is launched, in case its index is lower 
than the index of the specified reference environment.  
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I.C. Possibility to Select Printing Languages 
 
 
A new button: Languages was added in the Print Manager window (called via the File > Print 
command).  
 
The button displays the Select Languages Visibility dialogue, which contains all languages defined 
in the current Language method and enables you to select those in which you want to print project 
data. 
The option: "Use language visibility settings defined in sheets editor", available in this dialogue, 
allows you to directly select the languages specified for the multi-language texts visualization (via the 
command View > Languages Visibility…). 
 
The Languages button is also available in the Print Preview window, where all currently selected 
printing languages are shown. 
 
 

I.D. New Functions in the PLC I/O Configuration Manager 
 

 
 A new command: Configuration of the channel address calculation in the Options menu 

allows you to define Channels default numbering format for all kinds of modules. 
 

 An Address pop-up command is available on each existing Module, allowing you to separately 
define or change the particular Channels numbering format and apply it to the respective 
Module. 

 
 It is now possible to import files of AML format from the Siemens' TIA Portal V14. 
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II. Enhancements in Existing Processes and Features 
 

II.A. Automatic Project Reparation 
 
 
A number of security improvements have been brought in the repairing processes, which are 
automatically run on corrupted projects at their opening or other particular conditions.  
 
Process failure management was implemented in a way that in case even a single reparation 
process fails, the project opening is blocked and a relevant message is displayed, containing 
information about the possible reasons and suggesting solutions for fixing the respective issue(s). 
 
 
 

II.B. Diagram Exportation 
 
 
When, for the execution of the File > Export > Diagram for SEE Publisher command, all project 
sheets are set to be exported in a single JSON file, the generation process sorts the sheets in the file 
in the same order in which they are displayed in the Sheet Explorer. 
 
 
 

II.C. Labels Exportation 
 

II.C.1. Ameliorations in the Label Export Process 
 
 

Sorting of the Exported Data 

When the data to export is set to be sorted by Location or by Sheet (in the Label export window), 
the sorting of the exported labels is performed, by respecting the following rules: 
 First, labels are sorted according to the specified data sorting criteria – "by Location" or "by 

Sheet". 
 After that the labels from each particular Location or Sheet are sorted alphanumerically. 

 
 

Equipment Extraction 

The label exportation process was improved to take into account Equipment that is not inserted in the 
Schematic Sheets (as, for example, terminals created in the Terminal Strip Editor), so the respective 
labels are also extracted. 
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Partex plugin for label export 

The fields: "Additive_Code1" to "Additive_Code9" were added to the neutral XML file that is 
generated at label export.  
When the Partex plugin is used for data extraction, the value of the "Additive_Code1" (from the 
neutral XML) is filled in the "Product code" field of the generated TXT file. 
 
 
 

II.C.2. Enhanced the Neutral XML Generation Process 
 
 

Introduced possibility to indicate the location of the neutral XML 

For this purpose, the process that is run following the execution of the Process > Export SEE 
labelling Export File now takes into account a setting already existing in the Label export window - 
used to set exportation of labels in particular manufacturer formats.  
As a result, the neutral XML is by default generated in the location specified by the path entered in 
the Files generated folder field (of the Label export window). 
 
When the field is empty (i.e. no label export performed yet), the neutral XML file is created in the 
folder that was used by the process as a default one until now: 
"C:\Users\<UserName>\AppData\Roaming\IGE+XAO\ExportLabel\". 
 
 

Generation of a log file 

At the end of the neutral XML file generation a relevant report is displayed, containing details about 
the executed process. 
 
 
 

II.D. Cabling Control  
 
 
The "Gauge of wires and connection points compatibility" cabling control process (run via Tools 
> Control…) is now able to analyse and handle situations when more than one wires are connected 
to the same connection point 
 
In the report that is generated at the end of the entire process, the results of this control are 
summarized in a relevant table 
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II.E. Electric Data Explorer 
 
 
In the Terminals / Pins tab, the execution of [Ctrl + Double click] on a Terminal strip displays a 
dialogue listing the terminals that belong to the clicked Terminal strip.  
The list provides you with the possibility to navigate to the Schematic sheets in which the particular 
terminals are inserted. 
 

With regard to these improvements, the [Ctrl + Double click] keyboard shortcut can no more be used to 
run the Open Connector / Open Terminal strip functionalities, and was removed from the respective 
contextual menus on connectors, terminals and pins (within the tab). 
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II.F. Equipment Catalogue  
 
 
The "Date of update" field in the Equipment Catalogue is updated or filled in (in case of empty value) 
at the execution of relevant functionalities, available in SEE Electrical Expert, which allow or initiate 
creation, importation or modification of Equipment Codes. 
 
However, there are particular cases in which the "Date of update" field is not updated.  
They are the following: 

 Modification of Equipment Codes directly in the Access base. 

 Download of Equipment Codes from CSV and XML files. 

 Download of Equipment Codes having ASCII Formatted format, dBase format and 
Class format. 

 Modification of a field value via the command Edit > Change field value…. 

 Modification of a field via the command Tools > Add or Modify field into 
multiple classes. 

 
 
 

II.G. Environment Manager  
 

II.G.1. Improved the Merge Environment Process 
 
 
It is no more necessary to select a merging option before executing the merge process – the 
"Options" frame was removed from the Merge environment dialogue. 
 
Whenever the process of merging the indicated reference environment into the local one is run, all 
elements that exist in the reference environment but are not present in the local environment are 
merged in it (as long as the respective elements were specified to be treated by the process).  
This is to say that only elements that are "new" for the local environment are imported inside it from 
the reference one.  
 
 
 

II.G.2. Optimized the Catalogue Updating Process  
 
 
When an update/synchronization is run, following the execution of the Environment > Update 
environment command, the process checks and compares only the respective "Date of update" 
fields in the Equipment Catalogues of the reference and local environments, instead of comparing all 
catalogue fields, as it was in the previous SEE Electrical Expert versions. 
 
In case, for a piece of equipment, the field is empty in both environments, the old updating process is 
run. 
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II.H. SEE Electrical Expert Configuration  
 
 
The plugins' names in the different languages were appropriately changed, and the available plugins 
are sorted alphanumerically in the list displayed within the Plugins Manager section of the SEE 
Electrical Expert Configuration window. 
 
 
 

II.I. PLC I/O Configuration Manage 
 
 
 The process run at the execution of the Option > Slf Generation command is now able to 

export interfaces in the generated PLC sheets, which is not possible though the Block 
generation process (run via the command Option > Block Generation). 

 
 It is no longer possible to add Channels on a Module that has an Equipment Code assigned to 

it. 
 
 
 

II.J. API 
 
 
When a main and additive Equipment Codes are defined via the API, the additive Equipment Codes 
are now correctly linked with the respective main ones. 


