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I. Changes and Enhancements Made in SEE Electrical 
Expert V4R3 Service Pack 2 (4.82/A final version) 
Compared to V4R3 Service Pack 1 (4.81/D) 

 

I.A. New Features and Enhancements 
 
 

SEE Electrical Expert Configuration 

▪ The available plugins are sorted alphanumerically in the Plugins Manager section of the 
SEE Electrical Expert Configuration window.   

 
 

Project 

▪ In case of failure of the repairing processes, automatically launched in particular cases, a 
report is displayed, containing information about the possible reasons and suggesting 
solutions for fixing the respective issues. 

 
 

Schematic Editor 

▪ The "Gauge of wires and connection points compatibility" cabling control process 
(that is activated in the dialogue called via the Tools > Control… command) able to 
analyse and handle situations when two wires are connected to the same connection 
point. 

▪ When, following the execution of the File > Export > Diagram for SEE Publisher 
command, all project sheets are set to be exported in a single JSON file, the respective 
process generates the sheets in the order they are sorted in the Sheet Explorer. 

 
 

Environment 

▪ A new pop-up command in the Environment Explorer enables creation of a Working 
Environment from the active one. This environment can be used and modified only by its 
creator, who can make it accessible for other users via a new Activate command. 

▪ A new command in the Environment Explorer enables comparison of the active 
environment with a temporary one created automatically from the current project, followed 
by automatic creation of a new environment that contains the differences between the 
compared environments.  

▪ A new mode in the Environment Manager enables synchronization of two environments 
from a V4R3 version of SEE Electrical Expert. 
Concerning the Catalogue, the synchronization works only with MDB format (SQL format 
will be managed in SEE Electrical Expert V5). 

▪ Optimization of the Catalogue updating process when Update environment is executed 
– the process checks only the field "Date of update" of the Equipment Catalogue (instead 
of checking all fields, as it was in the previous versions). 

▪ Optimization of the symbols synchronization process. 
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Label Export 

▪ Possible to indicate where the Neutral XML file is to be generated, i.e. to specify the path 
to the location of this file.  

▪ Partex plugin for label export: 

 Added fields: "Additive_Code1" to "Additive_Code9" in the Neutral XML file.  

 In the "Product code" field (of the Partex format) added the value of the 
"Additive_Code1" field (from the Neutral XML file). 

▪ When the data to export is set to be sorted by "Location" or by "Sheet", the exported 
Labels are first sorted according to the specified criteria and then alphanumerical sorting 
of the Labels is performed within the respective Locations or Sheets.  

▪ Equipment not inserted in the Schematic Sheets (as terminals created in the Terminal 
Strip Editor) is also taken into account by the process, and the respective Labels – 
extracted. 

 
 

PLC I/O Configuration Manager 

▪ New command: Moduls address calculation mapping in the Options menu allows 
defining, for all kinds of modules, the Channels default numbering format. 

▪ An Address pop-up command is available on each existing Module, allowing you to 
separately define or change the particular Channels numbering format and apply it to the 
respective Module. 

▪ When a Module has an Equipment Code assigned, it is no longer possible to add 
Channels on it.  

▪ Possible to import files of AML format from the Siemens' TIA Portal V14. 
 
 

Printing 

▪ New button: Languages, available in both the Print Manager and Print Preview 
windows, allows selecting the printing language. 

 
 

API 

▪ Possible to define a main Equipment Code and linked additive Equipment Codes via API. 
 
 
 

I.B. Fixed Issues 
 
 
2D Panel 

BM23186 The equipment code of the same panel being present in two layout 
sheets (on the same location) is counted twice in the generated Part 
List. 

BM23408 Impossible to insert a Connector on a rail. 
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3D Panel 

BM23571 Crash of SEE Electrical Expert when loading components in the 3D 
Panel. 

 
 
Cables 

BM22239 At the first insertion of a cable, its "CODE" attribute (of Catalog type) 
does not retrieve the relevant information.  

BM604715 In a multi-wire cable, wire function is removed when changing the 
cable/strands colours. 

 
 
Copy/Paste 

BM20752 The options "Merge" and "Create New", set for the "Copy/Paste Type" 
in the General edition settings, do not work.  

BM21848 Terminal numbers not kept after Cut/Paste Special.  

BM22271 After copying/pasting particular Parameter Sheets, within the 
Parameter Sheet Explorer, the new ones (those that have been 
pasted) are not available for selection in the respective Editing method. 

 
 
DWG/DXF 

BM1602358 When importing an AutoCad file, the lines are converted into splines.  

 
 
Electric Data Explorer 

BM22983 Wrong sorting of the Sheets when they have numbers with indexes (i.e. 
a complement format is defined for the sheets numbering in the 
respective method). 

BM1300983 The "Ctrl+ Double click" keyboard shortcut does not work in the Cable 
tab for opening a Terminal Strip. 

 
 
Environment Manager 

BM605189 Incorrect message displayed when the application is launched. 

 
 
Environment Methods 

BM22758 Wrong characters (after Methods validation) when specific initial values 
are defined for default attributes in the Sheets and Attributes Method. 

 
 
Harness Editor 

BM14272 The Undo functionality does not work properly 

BM23412 The data displayed on the Harness Sheet disappears when the 
"Harness Links Visibility" icon is activated. 
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Installation 

BM23106 Translated module name available for selection in Custom installation 
mode. 

BM23220 When French language is selected during the installation and then 
English language is selected for running the software, the English "Tips 
of the day" are missing. 

BM23430 The "Cable identification" plugin is automatically enabled. 

BM23469 Impossible to launch SEE Electrical Expert without Administration 
rights. 

 
 
Label Export 

BM23486 The IDH file, generated for Cembre, does not contain the Labels 

BM1401575 In the generated file, the wire labels number, when calculated according 
to the number of the connected connection points, is distributed on 
several lines instead of the being displayed (in total) on a single line 
only. 

 
 
List Reports 

BM1601863 
Filters on Terminal symbols not taken into consideration (not applied) 
by the generation process. 

 
Messages 

BM23277 Incorrect translation of an option for the Update WD attributes and 
connection points of symbol process in the French version 

BM23308 Texts to homogenize in the Technical Information concerning the 
software protection. 

BM23328 In the French version, incorrect translation of the tooltip to the icon for 
filtering harnesses. 

BM23343 Several incorrect translations in the French version. 

BM23344 In the French version, when an existing Equipment Code is entered in 
the Equipment Catalogue, the displayed message is in English. 

BM23347 Incorrect translations in the SEE Electrical Expert Configurator. 

BM23378 Incorrect translation in the Harness Method. 

BM23417 Incorrect message when checking Internet protection (in the French 
version). 

BM23418 Options not completely visible in the Connector and Pin Association 
for Insertion Method. 

BM23424 Display error for an option in the Connector and Pin Association for 
Insertion Method. 

BM23456 In the English version, some fields appear in French in the dialogue 
called through the Modify field/Add field buttons in the See Catalog 
Utilities Tool (accessed via the Tools > Add or Modify field into 
multiple classes command in the Equipment Catalogue). 
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BM23487 Some incorrect translations in the French version. 

BM23552 Problem of options display in the Update of symbols, illustrations 
and connections inserted in sheets window. 

BM23579 Translation of the commands Import > Comments… / Export > 
Comments… 

BM23580 Bad translation in the "Internet protection" configurator. 

BM23603 Text to correct in the Wire Extremities dialogue. 

BM1300977 Incorrect translation of a message displayed at project opening in the 
Spanish version.  

BM1300979 In the Spanish version, incorrect translation in the General Settings 
(within the dialogue called via Options > Settings) for. 

BM1300980 In the Spanish version, incomplete visibility of an option in the window 
called via the File > Update according to the environment 
command. 

BM1300985 In the Spanish version, incorrect translation in the Cross-References 
Method. 

 
 
Migration 

BM23130 Lost translation in a project migrated from V3R7 to V4R2. 

BM605173 After migration of a project from V3R7 to V4R2, the WD attributes on 
some OPR symbols are lost.  

 
 
Multi Language 

BM605195 The modification of the location description for a Location symbol is not 
propagated to the other Location symbols from the same location  

 
 
Multi-User 

BM605203 Problem with project opening after using Undo/Redo. 

BM1300953 In the Sheet tab of the Electric Data Explorer, the Sheets opened by 
another user are not displayed in red pen. 

 
 
Other 

BM23398 See Change Symbol Attributes Properties Plugin dialogue (called 
via Tools > SEE Change Symbol Attributes Properties Plugin): 
Error message displayed when loading project attributes. 

BM23400 Cancel button is missing in the See Change Symbol Attributes 
Properties Plugin dialogue. 

BM23402 No attribute is selected by default after attributes have been loaded 
within the See Change Symbol Attributes Properties Plugin 
dialogue. 
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PLC I/O Manager 

BM23589 Crash when pasting a Module. 

BM605209 Crash after creation of a new configuration. 

BM605210 Impossible to select an Equipment Code at creation of a new API via 
the File > New command. 

BM605211 The saved PLC configuration is removed when the project is closed. 

 
 
Protection 

BM23090 Impossible to change the software language when SEE Electrical 
Expert is using ILS protection.  

BM23287 Crash at clicking the Protection Key section in the SEE Electrical 
Expert Configuration window when the "Network license key (HaspLM 
server)" protection type is used. 

BM23494 With a "Network license key (HaspLM server)" license, nothing is 
displayed when clicking <?> > Technical Information or <?> > About.  

 
 
Schematic Editor 

BM15408 No refresh when the visibility of the empty attributes is 
activated/deactivated. 

BM19105 Impossible to keep the size of the "search" dialogue. 

BM23232 When multiple OPR symbols are inserted, the WD attributes, which are 
to display the respective Source and Destination tags, have wrong 
values.  

BM23376 In the Properties dialogues of the "Channel" and "Line Group" 
symbols, it is impossible to enable the "Limited propagation" check 
box.  

BM23393 When saving reports resulting from the Tools > Control… process, the 
generated file is empty. 

BM605140 Dynamic zoom does not work when a command (from the Edit or 
Insert menu) is activated. 

 
 
Sheet Explorer 

BM23330 When the icon for displaying only texts and drawings is activated, 
grouped entities or objects are not taken into account. 

 
 
Symbol Tagging 

BM18852 Impossible to freeze or unfreeze the cable Label. 

BM1401569 When a piece of equipment is being inserted in the Layout sheet, its tag 
(displayed in the respective CAD Properties dialogue) is incorrect 
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Synoptic Editor 

BM605149 When a prefix and/or a suffix are used for the name of a symbol's 
attribute, the respective value is printed twice (overwritten). 

 
 
Terminals 

BM23421 Crash when renumbering terminals. 

 
 
Translation Module 

BM23452 The option "Do not translate words containing at least one not 
translatable characters" (in the Translation Settings dialogue) does 
not work correctly. 

 
 
 

I.C. Known Issues and Workarounds 
 
 

Issues to be fixed in V4R3 Service Pack 2 (4.82/B) 

 
3D Panel 

BM23613 The 3D Panel sheets are duplicated in the EDE – each displayed also 
within the Tree view of sheets, under the Schematic Sheet with the 
same number. 

 
 
Environment Catalogue 

BM23582 The "Date of update" field is not updated after an import from the SEE 
Web Catalog. 

 
 
Environment Manager 

BM23453 When comparing two environments with the "New only" option 
activated, the modified entities are also treated. 

 
 
Harness Editor 

BM23439 The filter on the tags of the Connective equipment connected to a 
Harness does not work correctly. 

 
 
Options & Variants 

BM23411 Impossible to assign a validity on existing texts and drawings after 
modification of the configuration. 

BM1300992 When generating a PDF file, the Validity… button is not available. 
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Other 

BM23523 Wire List Import: Error message during the creation of SEE Electrical 
Expert sheets. 

 
 
PLC I/O Manager 

BM23586 At SLF generation, the second part of a rack is not generated and error 
message displayed. 

BM23588 The SLF generation time is multiplied by 10 compared to the time 
consumed in V4R2 for the same configuration. 

BM23590 The SLF generation does not work for a configuration with an interface. 

BM23591 When a configuration is updated, the sheets of the other configuration 
are removed. 

BM605229 Crash when launching the tool. 

 
 
Protection 

BM23575 Error message when launching the software with a "Local license key 
(Dongle)" protection, if the "Automatically take the module during 
opening multi-languages project" option is disabled (in the 
Advanced protection settings section of the SEE Electrical Expert 
Configurator). 

BM23584 Selection of an application language in the Configurator is not possible 
with an Internet licence 

BM23593 Modules are abnormally Free with an Internet licence. 

 
 
 

I.D. Limitations and Restrictions 
 
 

I.D.1. SEE Electrical Expert 
 
 
 SEE Electrical Expert cannot be run under Windows XP. 

 
 SEE Electrical Expert V4R3 needs a Flex LM version that is equal or upper to 11.14.02 to use 

this type of protection. The "Visual C++ Redistribute for Visual Studio 2015" component has 
to be installed on the server where Flex LM is installed. Normally, this component is 
automatically installed with the Windows Update. 

 
 Project maximal size is 1.8 GB. 
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 The multi-language features of a project are protected by the "Translation" license.  

Editing texts or attributes is possible to be carried out in all project languages only provided you 
have the "Translation" module included in your license. 
If you do not have the "Translation" module, you are allowed to consult the project in each project 
language but modifications can only be made in the "main" language. 

 
 The migration process does not recreate the hyperlinks in projects created with V4R1 or 

previous versions of SEE Electrical Expert. To have the hyperlinks available on migrated 
projects, you have to rebuild the cross references and then generate the part lists and table of 
contents again. 

 
 PDF Export: To activate the hyperlinks in Adobe Acrobat Pro, click Edit > Preferences…, 

select the Documents category in the left pane of the displayed Preferences window  and then 
choose "Never" from the drop-down list available for the "View documents in PDF/A mode" 
setting. 

 
 SEE Workspace (SWS files generated through Options/Customize - Export button) that were 

saved with versions lower or equal to V4R1 are not supported by V4R3. 
 
 SEE Equipment Database supports MS SQL Server 2008, 2012 and 2014 ("Part List Manager" 

license is required). 
 
 Versions greater or equal to V4 do no longer support MS SQL or Oracle database for the 

parts list processes. 
 
 If you are using Local Server Borrowing (LSB) or Internet License Server (ILS) Protection, it is 

impossible to change the software language after the installation. 
 
 
 

I.D.2. SEE Electrical 3D Panel 
 
 
 SEE Electrical 3D Panel has its own installer and is not installed with SEE Electrical Expert.  

 
 
 

I.D.3. SEE Automatic Diagram Generation Module 
 
 

 The SEE Automatic Diagram Generation module has its own installer and is not installed with 
SEE Electrical Expert. 

 This module is protected by a license. 
 The SEE Automatic Diagram Generation module needs MS Excel and is compatible with the 

32 and 64 bits versions of MS Excel 2010, 2013 and 2016. 
 It is not possible to add variables for layout or harness blocks in the Block Param Editor. 
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I.D.4. Concurrent Engineering Module (Multi-User Mode) 
 
 
 The Concurrent Engineering module (Multi-User mode) is compatible with MS SQL Server 

2012 and 2014 databases for project data storage. 
 The Concurrent Engineering module needs SEE User Access. 
 In Multi-User mode (Concurrent Engineering module), the option "Automatically save project 

content when closing project" (in the Settings window of SEE Electrical Expert) does not 
work when not enabled. 

 
 
 

I.D.5. Open Data Module 
 
 
 The Open Data module needs MS Excel and is compatible only with the 32-bits version. 

 
 
 

I.D.6. End Fitting Module 
 
 
 To migrate the data stored (until V4R1) in cable attributes to the new extremity attributes in 

V4R3, the "End Fitting migration to V4R3 (4.80)" plugin must be installed and activated. 
 
 
 

I.D.7. 3D Panel For SolidWorks Module 
 
 
 The "old" 3D Panel for SolidWorks module is no longer supported by SEE Electrical Expert 

versions that are greater or equal to V4R3. 
 A 3D panel layout created with this module (before V4R3) cannot be migrated to the new 3D 

Panel module. 
 
 
 

I.D.8. Macro 
 
 
 To execute a macro on SEE Electrical Expert versions greater or equal to V4R3, you need to 

have a VBA version 7.1 32 bit (not 64 bit) installed.  
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I.D.9. SmarTeam Integration Module 
 
 
 The SmarTeam Integration module of SEE Electrical Expert V4, V4R1, V4R2, and V4R3 

supports the SmarTeam releases V5R19 to V5R27. 
 
 
 

I.E. Compatibility with Other IGE+XAO Products 
 
 

I.E.1. SEE Project Manager 
 
 
SEE Electrical Expert V4R3 Service Pack 2 (4.82/A) is compatible with SEE Project Manager V8R2 
SP 7 - Patch K or L, and V8R3 Patch C. 
 
 
 

I.E.2. SEE Access Control 
 
 
SEE Electrical Expert V4R3 Service Pack 2 (4.82/A) supports only the version 4.50/E of SEE User 
Access. 
Customers using older SEE User Access versions have to migrate their databases via the SEE User 
Access Admin Tool. 
 
 
 

I.E.3. SEE Automatic Diagram Generation 
 
 
SEE Electrical Expert V4R3 Service Pack 2 (4.82/A) supports the version V4.80/A of SEE Automatic 
Diagram Generation. 
 
 
 

I.E.4. SEE Electrical 3D Panel 
 
 
SEE Electrical Expert V4R3 Service Pack 2 (4.82/A) supports V1R4 Service Pack 1 of SEE 
Electrical 3D Panel. 
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I.E.5. SEE Electrical Jigboard 
 
 
SEE Electrical Expert V4R3 Service Pack 2 (4.82/A) supports the version V4R7 of SEE Electrical 
Jigboard.  
 
 
 

I.F. System Requirements 
 
 

I.F.1. Advisable System Configuration 
 
 

For Mono-User Mode: 

▪ Microsoft Windows 7 Home Premium, Professional, Ultimate, Enterprise  
▪ 64 bits Operating System to be installed on a 64 bits computer 
▪ Processor: i3 class, 2 GHz. 
▪ RAM: 4 GB. 
▪ 500 MB of free disk space required for the installation. 
▪ In order to optimize the SEE Electrical Expert performance on your computer, it is 

recommended that you use an SSD hard drive 
▪ Graphic Card: 1280 x 1024. 

 
 

For Multi-User Mode (Concurrent Engineering): 

The requirements are different for the Server and for the Client. 
 
For the Server: 
▪ Microsoft Windows Server 2008 R2 64 bits or newer. 
▪ Microsoft SQL Server 2008 R2 (PROFESSIONAL version strongly 

recommended; EXPRESS EDITION version possible to be used with limitations). 
▪ Processor: i7 class, 3 GHz. 
▪ RAM: 12 GB (+ 1 GB by client). 
▪ 200 GB of free disk space required for the installation. 
▪ LAN (Network Card): 1 GB. 
 
For the Client: 
▪ Microsoft Windows 7 (64 bits). 
▪ Processor: i3 class, 2 GHz. 
▪ RAM: 4 GB. 
▪ 500 MB of free disk space required for the installation. 
▪ In order to optimize the SEE Electrical Expert performance on your computer, it is 

recommended that you use an SSD hard drive 
▪ Network Card: 1 GB. 
▪ Graphic Card: 1280 x 1024. 
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For using the 3D Panel: 

▪ Microsoft Windows 7 Home Premium, Professional, Ultimate, Enterprise. 
▪ Processor: i5 class, 2 GHz. 
▪ RAM: 4 GB. 
▪ 1 GB of free disk space required for the installation with the 3D Parts library, 

provided by default. 
▪ Graphic Card: full support of OpenGl required, as well as 1 GB of dedicated 

memory. 
 
 
 

I.F.2. Windows Compatibility 
 
 
SEE Electrical Expert V4R3 supports: 
 Microsoft Windows 10 Pro (32 and 64 bits), as well as Microsoft Windows 10 Enterprise (32 

and 64 bits). 
 Microsoft Windows 8 and Microsoft Windows 8.1 (except for the RT version for mobile 

devices). 
 Microsoft Windows 7. 
 

Microsoft Windows XP is not supported by SEE Electrical Expert V4R3. 
 
 
 

I.F.3. Virtual Solutions Compatibility 
 
 
SEE Project Manager and SEE Electrical Expert are compatible with the Microsoft App-V and 
VMWare virtual solutions. 
 

Microsoft App-V or VMWare 

 
No compatibility issues reported for these two virtual solutions. 
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