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1 -  New Features  

1.1 Cable Installation Panel 
 

The Cable Installation Panel is available only in the Layout sheets. This command gives you the possibility 
to display the routing inside the cabinet, mark the wires as installed or uninstalled and generate a report 
of the installation progress. To launch the Cable Installation Panel execute the Tools > Cable Installation 
Panel command.  

Be aware that you can also sort the wire list according to your personal preferences via the available 
pop-up commands. 

 

1.2 Generating a Log File in Batch Mode Using Windows System Variables  
 

It is now possible to generate a Log file in Batch Mode using Windows system variables. All depends from 
the value of the LOGFILE parameter. 

- If the LOGFILE parameter value points to a certain user profile, a Log file will be generated in the 
Logs directory of the given user.  

- If the LOGFILE parameter value points to a certain user shell folder, a Log file will be generated in 
the Logs directory, located within the specified user shell folder. 

 

1.3 Printing Layout Sheet with Generated Routes 
 
The "Routes" option now allows you to print the Layout sheet(s) together with the generated routes. To 
enable this feature go to the File menu, select the Print command, click the Visibility button and enable 
the "Routes" option.  
 
Keep in mind that the "Display Routing" option, located in the View section (Layout sheet type) of the 
Settings window has to be enabled for the routes to be printed. 
 

1.4 Pasting Elements from SEE Viewer to SEE Electrical Expert  
 
Elements, such as texts, connections, symbols, etc., copied from SEE Viewer can be inserted into SEE 
Electrical Expert via the Paste command. 
 

1.5 Switching Pins within Logical Connector 
 
It is possible to replace a pin inserted in a logical connector by another pin, given that the necessary 
symbols are specified in the Connector and Pin Association for Insertion Method within the Connectors 
category of the Methods window. Select the pin (inserted in a logical connector), right-click and execute 
either Change to Backshell or Change to pin, depending on the change you want to make. 
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1.6 Assigning / Changing Validity  
 
It is possible to assign or change the validity of texts, drawings, graphical locations, OPR symbols and 
symbols without connection points. To do so, select the respective entity, right-click and execute the 
Change Validity… command. Within the Validity Builder window, you can assign a new validity or edit 
the existing one. 
See also the Variants Management Improvements section. 
 

1.7 Exporting Sheets in JSON Format 
 
This new feature allows conversion of project data in a language independent text format. It uses a 
library provided with the application to describe the exported entities. You can export Functional 
Diagram(s) (Connection Mode project) or Wiring Diagram(s) (Wire Mode project). To export in JSON 
Format execute the File > Export JSON File(s) command. 
 

1.8 Exporting a Simulation File 
 
This new component converts Electrical Diagram into set of logical equations, which describe the 
Electrical Diagram behavior. To export a Simulation file execute the File > Export Simulation File 
command. The file is exported in XML format. 
 

1.9 Exporting Symbols or Illustrations in SEE Electrical Jigboard Format 
 
This functionality converts symbols, defined in SEE Electrical Expert environment, into symbols that can 
be used in SEE Electrical Jigboard (symbols in XML format). To convert symbols in SEE Electrical Jigboard 
Format, execute the Export > Format of SEE Electrical Jigboard pop-up command (on folder or symbol's 
level in the Symbol Explorer window). 
 

1.10 Undo/Redo in Multiuser Mode  
 
In Multiuser mode the Undo/Redo Explorer now displays a list of all actions executed by all the users 
working on the same project (a project stored on SQL Repository on a given server location). Depending 
on the options specified in SEE Electrical Expert Configuration window, you are allowed to undo or redo 
an action performed by you or the other user(s). See also the New Options in "SEE Electrical Expert 
Configuration" Window section.  
 

1.11 New Toolbar Icon 
 

The new "Highlight Text and Drawings" icon ( ) has been added in Sheet Explorer window, and in the 
Visibility toolbar of the main SEE Electrical Expert window. 

- The "Highlight Text and Drawings" icon, located in the Sheet Explorer window, displays only the  
text and the drawings in Preview pane of the selected sheet, while hiding everything else. 
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- The "Highlight Text and Drawings" icon, located in the Visibility toolbar, highlights the text and 
the drawings in the currently opened sheet, without hiding the remaining part of the sheet. 

 
A new setting in the Line and Color method allows you to define the highlight colour for the texts and 
drawings. 
 

1.12 New Controls Method 
 
The Controls Method has been added in the Project section of the Methods window.  The method allows 
management of the default values of the controls. You can define whether the control will be started 
when the project is closed, whether the control is mandatory, as well as the priority of the control.  
 

1.13 New Tab in the Connector and Pin Association for Insertion Method  
 
The Equipment connectors attributes management tab, located in Connector and Pin Association for 
Insertion Method (Connectors section of the Methods window), allows you to choose whether to 
synchronise the equipment attributes or the equipment attributes to be inherited by the connector. 
 

1.14 New Harness Working Modes in the "Methods" Window 
 
The Harness section in the Methods window now allows you to choose between two Harness working 
modes:  

- General mode 
- Manufacturing mode 

 
Working in Manufacturing mode allows to define the exact position on the branch of the inserted 
accessories and protections, relative to the branches extremities – connective equipment or nodes.  
The insertion of harness accessories depends on the chosen working mode. The working mode affects 
the following symbols with Harness Design Behaviour and functions: Harness Accessory Adapter, Harness 
Accessory Clamp, Harness Accessory Label, and Harness Accessory. 
 
The CAD Properties window of a harness protection also displays different attributes depending on the 
chosen working mode. The work in Manufacturing mode forbids the insertion of a harness protection on 
a branch without defined length. 

 

1.15 New Options in the "Settings" Window  
 
The new "Execute 'Controls at close' even if project was not modified" option, located in the General 
section, launches the controls, defined as "Control at close", when closing the project even if no 
modification in the project was made. 
 
The new "Black Box Selection" option, located in the Schematic section of the Coordinates & Cursor 
category, allows you to define whether to select the Black Box by clicking anywhere within it, or by 
clicking only on its contours. 
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The new "Tag status color" area and its respective options, located in the Schematic, Harness and 
Layout sections of the View category, allow you to define different colors for the differently defined tags 
(Frozen tag, External tag, and Manual tag).  
 
The new "Recalculate order in case of tag modification" option, located in the 
Schematic/Synoptic/Harness/Terminal Strip sections of the Edit category, allow choosing whether to 
keep the tag order or compute this order when the tag is modified.  
 

1.16 Modifications in SEE Electrical Expert Configuration Tool 
 
New Options in SEE Electrical Expert Configuration Tool 
 
The new "Turn on support for high-DPI resolutions" option, located in the Editor Appearance section of 
the General category, allows you to enlarge all items within SEE Electrical Expert. For the option to take 
effect you also have to set a custom scaling level from the Control Panel of the Operating System. 
 
The new "Application language" option, located in the Editor Appearance section of the General 
category, allows switching the initially installed language, in case your protection key allows multi-
language use and the corresponding language package is installed. 
 
The new "Allow multiuser undo" option, located in the General Settings section of the Multi-User 
category, allows you to define whether other users can use Undo command in the same project in 
Multiuser mode. 
 
The new "Length of operation history" field, located in the General Settings section of the Multi-User 
category, allows you to define for how long the operation history in Multiuser mode will be stored. 
 
New Sections in SEE Electrical Expert Configuration Tool 
 
The new Logging Settings section, located in the General category, allows you to define the settings for 
the logging of the application behavior.   
 
The new Advanced section, located in the Security category, allows you to define whether to start SEE 
Electrical Expert with Translation license.  
 

1.17 New Tabs in the Electric Data Explorer 
 
The new Errors tab lists all errors generated during the different electrical processes. You are allowed to 
delete an error, mark an error as corrected/not corrected (via a context menu on the respective error), 
or filter the displayed errors (list only warnings, or only corrected errors). 
 
The new Sheets tab displays a tree view of the currently opened project and allows you to open the 
selected sheet, or to open the full Sheet Explorer. 
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1.18 New Fields in the Equipment Catalog 
 

The following new fields have been added in the Equipment Catalog:"Start Block", "Intermediary Block", 
and "End Block". Those fields have assigned respectively the functions "PLC: START BLOCK", "PLC: 
INTERMEDIARY BLOCK" and "PLC: END BLOCK". They enable you to assign one or several blocks to the 
equipment code. 

1.19 New Tagging Mode 
 
The "Semi-Automatic Tagging Without Uniqueness" tagging mode option is now available at 
project/template creation via the File > New Project command > Properties button. In this tagging 
mode, it is possible to use duplicated components tags, because the tag of the components is composed 
from the hidden system attribute DEVICE_ID and the component Tag, which is visible. 
 

1.20 New Connection Point Attribute 
 
The new Default Contact Order attribute, located in CAD Attributes window of a connection point (in 
the Symbol Editor), allows you to define a default integer value for the "Contact Order" attribute of the 
wire extremity that will be connected to this connection point. This value will be visible in the Schematic 
sheet only if you insert the $CONTACT_ORDER metacommand. 
 

1.21 New Attributes in "Wire Extremities" Window 
 
The "Extraction information" and "Soldered Extremity" attributes have been added in the Wire 
Extremities window. 
 

- The "Extraction information" attribute displays information about performed extraction, 
retrieved by the $Extraction_Info metacommand. 

- The "Soldered Extremity" allows you to define whether the wire extremity to be soldered or not. 
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2 -  Improvements to Existing Commands  

2.1 Ability to Assign Keyboard Key for Symbol Rotation 
 
You are allowed to rotate a symbol to 90, 180 or 270 degrees. However, it is now possible to define a 

keyboard shortcut for symbol rotation. To do so, execute the Options > Customize command > select 

the "Other" category, then select "Increase angle of inserting symbol" in the Commands pane and assign 
the shortcut and activate it.  
 

2.2 Automatic Tagging on Harness Nodes 
 
The harness nodes are now automatically tagged. The tag increments automatically on each node. Each 
separate harness is tagged separately. To make the tagging visible activate the Electrical Point Visibility (

). 
 

2.3 Automatic Zoom on Searched Entities  
 
When you perform a search for text, attribute or equipment code (via the Edit > Search > Text or 
Attribute or Edit > Search > Equipment Code commands), the sheet where the element is located opens, 
the element is zoomed and yellow flag points at it. 
 

2.4 AWG Standard Improvements 
 
Activating the AWG standard from the Standards Method now enables you to: 

- Import an external file that extends the list of gauges (Import button); 
- Clear the imported file (Clear button); 
- Export the currently active values (Export button). 

 

2.5 Wire Mode Migration Process Improvements 
 
The migration to Wire Mode process (launched when a normal project is saved as project of type "Wire 
Connectivity") checks the base project for errors and warnings and decides whether to convert the 
project. 

- If errors are detected during the conversion, the conversion process is stopped and the 
project/template is not saved. Such error is the existence of forbidden elements (tags, numbers, 
etc.) in the base project. 

- If only warnings are detected, the conversion process continues and the project/template is 
converted to type "Wire Connectivity". The conversion process can detect the following warning 
types: 
 - Deletion of Unconnected Wires; 

- Wires Branched at Point; 
- Superposed Symbols. 

For each warning type, the conversion process takes actions according to the set rules, so that 
the project is converted and saved. 
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2.6 Variants Management Improvements 
 
You are now allowed to edit the existing variant definitions xml file or to create a new one. 
 

- If no variant definitions xml file has been loaded, clicking on the Edit Variants button in the 
Variants Management tab of the Project Properties opens an empty Validity Builder window 
and allows you to create new variant definitions.  

- If a variant definitions xml file has been loaded, clicking on the Edit Variants button opens the 
Validity Builder window with the loaded variants definitions and allows you to edit them. 

 

2.7 Printing Area Improvements  
 
When trying to print part of a sheet ("Selected Area" radio button in Print Manager window), without 
having defined the printing area first, an information message reminding you about this appears.  To 
proceed, define the printing area. 
 

2.8 Improvement in the "CAD Properties Window"  
 
The Tag of the selected element, which was previously displayed as title of the CAD Properties window, 
has been moved into a separate Tag field.  
 

- The title of the window now displays CAD Properties, instead of the element's tag. 
- The content of the Tag field can be copied, but cannot be modified.  

 

2.9 Improvements in the "Control Process Summary" Window 
 
The Control Process Summary report window, which appears after clicking the Execute button from the 
Control Process window, has been improved. The Control Process Summary report window now displays 
detailed information about all controls (Signal, Device, Terminal Strip and Connector, Cabling, Synoptic, 
Harness, and Illustration controls). 
 

2.10 Improvements in the "Update of symbols, illustrations and connections 
inserted in sheets" Window 

 
The "Definitions to Update" area has been moved from the Process tab to the Application Domain tab. 
A new option allowing you to update the connections inserted in the sheet has been added in the 
"Elements to Update" area.  
 
The new "Signals" area (with its respective options), has been added into the Application Domain tab. It 
allows you to define which signal attributes to be updated. 
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