
SEE Electrical Expert V4R3 Service Pack 1    What's new?   
 

 p. 1 

 
 
 
 

SEE Electrical Expert V4R3 Service Pack 1  
What's new? 

 
 
 
 

 
 
 
 
 
 
 
 
 
  



SEE Electrical Expert V4R3 Service Pack 1    What's new?   
 

 p. 2 

Table of Contents 

1 - New Features and Enhancements ..................................................................................................... 3 

1.1 APIs/Plugins Enhancements .......................................................................................................... 3 

1.2 Compatibility Enhancements ........................................................................................................ 3 

1.3 Enhancements Common to Schematic, Synoptic, Harness and Layout Sheets ............................ 3 

1.4 Enhancements in the File Menu .................................................................................................... 4 

1.5 Exporting Project and Sheet Attributes in JSON File(s) ................................................................. 4 

1.6 Exporting Several Sheets in One JSON File .................................................................................... 4 

1.7 Improvements in the Electric Data Explorer ................................................................................. 4 

1.8 Improvements in the Harness Sheet ............................................................................................. 5 

1.9 Improvements in the Part List Extraction/Generation Process ..................................................... 6 

1.10 Improvements in the Project Migration Process........................................................................... 6 

1.11 Improvements in the SEE Electrical 3D Panel Concerning SEE Electrical Expert ........................... 7 

1.12 New Process for Label Export ........................................................................................................ 7 

1.13 SEE Catalogue Utilities Tool ........................................................................................................... 8 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



SEE Electrical Expert V4R3 Service Pack 1    What's new?   
 

 p. 3 

1 -  New Features and Enhancements  

 

1.1 APIs/Plugins Enhancements  
 
SEE Electrical Expert allows you to: 

- Use several plugins to start the same event. The event is executed in the order of loading of 
plugins. 

- Create new repository via plugins, APIs or VBA. 
- Export JSON files automatically via a VBA API. 

 
The PDF Comment Import plugin has been improved to use the new XML format of the comments. 
 

1.2 Compatibility Enhancements 
 
SEE Electrical Expert V4R3 Service Pack 1 (V4.81/A) is now compatible with: 

- V4.73 of SEE Electrical PLM application set. 
- V4R7 of SEE Electrical Jigboard. 

 

1.3 Enhancements Common to Schematic, Synoptic, Harness and Layout 
Sheets 

 
Modifying several attributes at the same time: The Symbol references window (accessible via the Edit > 
Change > Text Properties or Attribute Properties command) allows you to modify simultaneously the 
properties of one or numerous attributes of the selected symbol or illustration. The properties can be 
modified by ticking the checkboxes, selecting values in the predefined lists, or entering a numerical value 
manually. A homonymous column exist for each property. All modifications of the attribute properties 
can be validated at once via the OK button.  
 
Copy/Paste text and drawings between different sheet types: SEE Electrical Expert V4R3 Service Pack 1 
allows you to: 

- Copy/Paste free texts and drawings between sheets of the same type, or sheets of different 
type, belonging to the same project. 

- Copy/Paste free texts and drawings between sheets of the same type, or sheets of different 
type, belonging to another project. 

 
Import of comments from XML file: The File > Import > Import comments… command allows you to 
import any comments contained in XML file (validated with the IGE-XAO_COMMENT_1.00.xsd file) into 
the respective SEE diagram. 
This functionality is available only if you have installed and enabled the PDF Comment Import Plug-In. 
 
Export of comments into XML file: The File > Export > Export comments to XML… command allows you 
to export any new comments, created in SEE Electrical Expert, into an XML file. The generated XML file is 
created according the IGE-XAO_COMMENT_1.00.xsd file, provided with your installation package. You 
are allowed to edit the comments contained in the XML file after the export. 
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Enhancements of the drawing of graphical objects: Pressing the Shift button while drawing different 
kinds of graphical objects allows you to create the respective object with correct/symmetric shape. 
For example, if you are drawing a rectangle, when you press and hold the Shift button the rectangle is 
transformed into a square. The Shift button support is available for the following types of graphical 
objects:  

- Arc 
- Arrows 
- Bezier 
- Ellipse 
- Fillet 
- Parabola 
- Polyline 
- Rectangle 
- Segment 
- Spline 

 

1.4 Enhancements in the File Menu 
 
Import/Export modifications:  All import/export processes have been grouped into sub-menus, 
accessible via the File > Import and File > Export commands.  
 
Renaming of commands: The Export JSON File(s) command (available in the File > Export sub-menu) has 
been renamed to Export diagram for SEE Publisher. 
 

1.5 Exporting Project and Sheet Attributes in JSON File(s) 
 
Regardless of whether you are exporting all sheets into a single JSON file, or each sheet into a separate 
JSON file, the exported file(s) contain the names and the values of the sheet attributes, as well as the 
names and values of the filled project attributes "FG1_TAG", "FG1_DESCRIPTION", "FG2_TAG", and 
"FG2_DESCRIPTION". Those attributes are defined via the metacommands "SPM_FG1_TAG", 
"SPM_FG1_DESCRIPTION", "SPM_FG2_TAG", and "SPM_FG2_DESCRIPTION". 
 

1.6 Exporting Several Sheets in One JSON File 
 
The new "Single JSON file with all sheets" option, located in the Export JSON window, allows you to 
export all sheets of the currently opened project in a single JSON file. The export process takes into 
account the sheet order, as well as the possible user defined sorting, specified in the Sheet Explorer. 
By default, the name of the project is proposed as name of the JSON file.  
 

1.7 Improvements in the Electric Data Explorer 
 
The Sheets tab of the Electric Data Explorer has been improved, and allows you to: 

- Open one or several sheets simultaneously. 
- Delete one or several sheets simultaneously. 
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- Create a sheet. 
- Rename a sheet or a group. 
- Modify the sheet number. 

 

1.8 Improvements in the Harness Sheet 
 
Automatic insertion of connective equipment: The Process > Automatic insertion of Connective 
Equipments of Harnesses command inserts automatically all the pieces of connective equipment 
assigned to a given harness in the respective Harness sheet. 

- The position of the connective devices on the respective Harness sheet depends on the settings 
specified in the Automatic insertion of Connective Equipments tab in the Harness method. 

- The Harness sheet into which the connective devices are inserted depends on whether the 
harness to which the connective devices are assigned is inserted in a Harness sheet or not. 

o In case the harness is inserted in a Harness sheet, the connective devices are inserted in 
the same sheet.  

o In case the harness is not inserted in a Harness sheet, the connective devices are 
inserted in a new sheet, located in the group you have specified in the Sheet Generation 
Destination Group field of the Automatic insertion of Connective Equipments tab in the 
Harness method. 

 
Appearance of the links of the automatically inserted connective equipment: 
After the connective devices are inserted in the respective Harness sheet, the connection(s) between 
them are represented by links. By default, the links between the connective devices are displayed. 

- The new  icon, available in the Visibility toolbar, allows you to show or hide the links. 

- The dropdown list next to the  icon allows you to choose the links of which harness to be 
displayed. The dropdown contains all the harnesses, as well as an empty record. It is active only 
when the links are visible. 

o If you select a harness from the list, the links between the connective devices associated 
with the selected harness are displayed.  

o If you select the empty record, all links are displayed. 
- The link(s) between the connective devices disappear if you connect the respective connective 

devices with harness branch(es). The links are displayed again if you delete/disconnect the 
harness branches. 

- If the diagram in the Schematic sheet is modified, the links in the respective Harness sheet are 
updated accordingly. 

o In case of deletion of a cable in the Schematic sheet, the link representing the cable in 
the Harness sheet is deleted as well. 

o In case of insertion of new connection in the Schematic sheet, a new link between the 
connected connective devices is automatically inserted in the Harness sheet. 

o In case of modification of the tag of a connective device, the link(s) from the respective 
connective device disappear. 

- The Show links with other connective equipments pop-up command allows you to display only 
the connective devices to which the selected device is connected. 
 
 



SEE Electrical Expert V4R3 Service Pack 1    What's new?   
 

 p. 6 

New filter in the Standard toolbar: The new  filter allows you to display only the connective devices 
associated to the selected harness.  
If the filter is enabled and you have selected a harness from the dropdown list on the right, during 
insertion or edition of a connective device only the equipment associated to the selected harness is 
displayed. 
 
Improvements in the Harness protection: A new filter allows you to choose only equipment codes with 
diameter greater or equal to the diameter of the branch. 
 
Insertion of harness accessory/splice area on a harness node: SEE Electrical Expert V4R3 Service Pack 1 
can detect the existing harness nodes. When you hover the cursor (with selected harness accessory or 

splice area symbol) over a node, the cursor changes to a large dot ( ), indicating that a node is 
detected. If you insert the harness accessory or splice area symbol on a node, the "Distance" attribute is 
set to 0 and "Near to" attribute takes the node's tag. 
 
Automatic proposal of harness label, based on the harness to which the connective devices are assigned:  
For the automatic proposal of harness label feature to work correctly, in the Schematic sheet you have 
to insert at least two connective devices, which are assigned to a certain harness and are connected with 
cable. 
Then, when you insert those connective devices (manually or automatically) in a Harness sheet, and 
connect them with harness branch, the name of the harness to which they are assigned will 
automatically be proposed as name of the newly inserted harness.  
 
New filter in the Existing Equipments window of symbols with Behaviour/Function "Harness Design 
Behaviour/Harness Other": The new filter located in the Equipment area of the Existing Equipments 
window (accessible via the CAD Attributes window) allows you to define which pieces of equipment will 
be displayed in the list. 

- If you select All, all available pieces of equipment are displayed (as if no filter is defined). 
- If you select Connective Equipment, only symbols with attribute "To be inserted in Harness 

branches" set to "Yes", and symbols with Behaviour/Function "Master/Splice", "Slave/Splice" 
and "Unique/Splice" are not displayed in the list. 

 

1.9 Improvements in the Part List Extraction/Generation Process 
 

SEE Electrical Expert allows you to extract or generate a Part List of a project that is not linked to any 
environment, or that is linked to an environment different from the original one. 

 

1.10 Improvements in the Project Migration Process 
 
The process of project migration has been enhanced.  

- If the migration of the Part list database fails, SEE Electrical Expert creates or recreates a new 
clean Part list database, so that the migration process can finish. At the end of the process, the 
Migration report dialogue shows a clear explanation of the problem. 
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1.11 Improvements in the SEE Electrical 3D Panel Concerning SEE Electrical 
Expert 

 
Compatibility:  SEE Electrical Expert V4R3 Service Pack 1 supports V1.4.1 of SEE Electrical 3D Panel 
module. 
 
General Improvements: 
 

- The Description column of the Components tab in SEE Electrical 3D Panel module now retrieves 
the description information of the equipment codes from SEE Electrical Expert. 

 
- The components in SEE Electrical 3D Panel module are updated automatically, in case of 

modification of the symbols inserted in the Schematic sheet of SEE Electrical Expert. 
 

- It is now possible to choose one equipment code per component directly in SEE Electrical 3D 
Panel. The component's attributes are then updated automatically according to the selected 
equipment code.  

 
- The properties of the wires created in SEE Electrical 3D Panel can now be specified directly in the 

SEE Electrical 3D Panel module. The wire properties no longer depend on the equipment code 
specified in the Signals Method > Internal Cable tab of SEE Electrical Expert. 
 

- SEE Electrical 3D Panel now retrieves not only the terminals inserted in the Schematic sheet, but 
also the spare terminals, stops and breaks. 
 

1.12 New Process for Label Export 
 
General Information: The new process for label export is based on the already existing WAGO label 
export process. 
It works in the following way: 

1. The label export process generates a neutral XML file, containing all the labelling information of 
the currently opened project.  

2. The information contained in this neutral XML file is then retrieved by the label export plugin(s), 
corresponding to the manufacturer selected by the user. 

3. Depending on the settings specified for each label export plugin, the label export process 
formats the information and generates the corresponding label file(s).  

 
Launching the Label Export process: Three new commands, located in the Process menu, allow you to 
start the export process. 

- The Export Label command launches the new Label export window, which allows you to set up 
the extraction options (location of the generated label files, the data to be extracted, etc.). 

 
- The Quick Export Label command directly generates label file(s) using the settings defined in the 

previous label generation. After execution of the command no window appear, therefore you 
cannot change any export settings. 
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- The Export SEE labelling Export File command generates the neutral XML file, containing all the 
labelling information of the current project. 
 

Configuring the Label Export process: The new Label area, located in the General section of the Settings 
window, allows you to specify the settings of the export process. You are allowed to set: 

- The calculation settings for the number of wires and the cable labels. 
- The label format of the cables. 
- The manufacturer software that will read the exported label file. If you define such software, at 

the end of the label export process, the label file will be opened with the specified software. 
 

New label export plugins: To use a certain plugin, you have to install it during the installation of SEE 
Electrical Expert, and then enable it from the Plugins section SEE Electrical Expert Configuration window.  
The following plugins are available: 

- Abb plugin for export label 
- Brady plugin for export label 
- Cembre plugin for export label 
- ContaClip plugin for export label  
- Grafoplast plugin for export label 
- Modernotecnica plugin for export label 
- Murrplastik – Murrtechnic plugin for export label 
- Partex plugin for export label 
- Wago plugin for export label  
- Weidmuller plugin for export label 

  

1.13 SEE Catalogue Utilities Tool 
 
The SEE Catalogue Utilities Tool has been included in V4R3 Service Pack 1 of SEE Electrical Expert.  
 
This tool displays all the classes of the environment and allows you to link a field from the Equipment 
Catalogue to several classes. It also allows you to create a new field or modify the properties of an 
existing field. 
You can launch the SEE Catalogue Utilities Tool in two ways: 

- From the Tools > SeeCatalogueUtilitiesTool command in the Equipment Catalog window. 
- From the .EXE file of the tool. 
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